Systems Engineering Software

System requirementsΒΆ

While our software may work on other operating systems, we officially only support the following:

  • Windows: 7, 8.x, 10
  • Linux: most modern distributions should be supported
  • Mac OS X: 10.10 (Yosemite) or newer, 64-bit

In principle, our software is a set of plug-ins for Eclipse, a cross platform IDE. Eclipse itself runs on Java. We only support running our software on the following:

  • Java: Oracle JDK version 8 update 31 (8u31) or newer (other JDK vendors not officially supported, JRE is not sufficient)
  • Eclipse: Mars Update 1 (4.5.1) (Modeling Tools package recommended)

In addition, the set of plug-ins is compatible with Eclipse Neon (4.6). Also here, the Modeling Tools package is recommended.

For a more complete overview of the operating systems support by various versions of Java, see:

For a more complete overview of the operating systems and Java versions supported by Eclipse, see: